LabyMod Feedback Client

SkyBlock Addon for 1.16.5


Dauermuted
Dauermuted
2021-08-14 15:25:00
4 Votes
Description

Hey,
I would suggest that the Hypixel SkyBlock Addon for the version 1.16.5 available, because I cant no really play on other versions where the addon is. If it denied then I will be fine and I did my best to suggest it.


Comments

No comments found Please sign in to leave a comment.